Widespread Service Provider Outage

Incident Report for Clover Sport

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 16:40 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 16:18 CDT

Identified

Due to an ongoing service provider issue, Clover Sport is experiencing intermittent issues at this time with multiple services impacted. We are working with our service provider to ensure service is restored as quickly as possible.
Posted Jun 12, 2025 - 15:54 CDT
This incident affected: Bypass Services (Orders, Payments, Loyalty / Rewards).